If we go to LibreOffice 5 on Raspbian Jessie PIXEL


LibreOffice 5.0 was released in mid-2015. In Raspbian Jessie is version 4 of LibreOffice which was integrated. Yet the version 5 of LibreOffice offers a significantly improved UI with better space management and a cleaner look. It offers a better interoperability with other suites desktop, thanks to improved filters manage non-standard formats



click for information about the levels.





attention!


LibreOffice update is done from Raspbian Stretch, which is currently in version “testing”. Do not make this change on a distribution that is useful without a backup of your data! It is advisable to carry out this operation on a dedicated microSD card. The blog framboise314 cannot be held responsible for any loss of data or malfunction of the modified version of Raspbian.


as usual we’ll start with the system update. I started with a fresh (25/11/2016) Jessie Raspbian I’ve updated completely before starting the transition to LibreOffice 5.0


update of the system


 sudo apt - get update sudo apt - get upgrade sudo apt - get dist-upgrade sudo rpi-update sudo apt - get autoremove 

once this over (you have time for coffee) you can check the version of Linux in use :


[$19459027]pi@raspberrypi:/etc/apt uname-a Linux raspberrypi 4.4.38 – v7 + #938 SMP Thu Dec 15 15:22:21 GMT 2016 GNU/Linux armv7l

the original version of LibreOffice



in Menu raspbian, click on Office and open for example Writer .]


image displayed at the opening of LibreOffice



in the help ( Help ) writer, click on the last line of the menu to display the version:



we see that it is a 4.3 libreoffice version that is integrated with Raspbian Jessie.



Writer



Calc



Draw



these images of version 4 will allow you to compare with the version 5 of LibreOffice menus.


change of filing


(Debian) Raspbian versions are named after the characters of Toy Story . We got Wheezy , then Jessie and here Stretch


currently the version of Raspbian Stretch is to “ Testing “. ” This is the version currently in development for the next stable version of Raspbian (Debian). It is also available under the name of the future version, i.e. Stretch (since April 25, 2015).


what interests us here, it’s that Stretch includes the version 5 of LibreOffice! So let’s change the depot used for the updates of the system by replacing Jessie by Stretch . It goes in the file sources.list we will first make a backup copy sources.list.org (as in every time we intervene in a 😉 configuration file)


[$19459027]pi@raspberrypi:~ cd/etc/apt pi@raspberrypi:/etc/apt $ sudo cp sources.list sources.list.org pi@raspberrypi:/etc/apt $ ls apt.conf.d preferences.d trusted.gpg trusted.gpg.d listchanges.conf sources.list.org trusted.gpg sources.list sources.list.d ~ pi@raspberrypi:/etc/apt $ sudo nano sources.list

once opened the file sources.list [] found


 deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free # Uncomment line below then 'apt - get update' rpi to enable 'apt - get source' #deb - src http://archive.raspbian.org/raspbian/ main contrib non-free rpi jessie 

what is changed by replacing jessie by stretch as below


 http://mirrordirector.raspbian.org/raspbian/ deb stretch main contrib non-free # Uncomment line below then 'apt - get update' rpi to enable 'apt - get source' #deb - CBC http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi 

now the deposit that will be used will be S tretch , the future version of Raspbian that already contains LibreOffice in version 5 🙂


taking into account of the new deposit


change sources.list are only appointed at the level of a configuration file. To take into account this change is through the command apt – get update which will take into account the content of the repository:


[$19459027]pi@raspberrypi:/etc/apt sudo apt – get update receipt of: 1 stretch http://mirrordirector.raspbian.org InRelease [15,0 kB] reached http://archive.raspberrypi.org jessie InRelease met http://archive.raspberrypi.org jessie/hand armhf Packages Reception of] : 2 http://mirrordirector.raspbian.org stretch/hand armhf Packages [11,6 MB] reached http://archive.raspberrypi.org armhf jessie/ui Packages…

installation of LibreOffice 5


you can now start installing LibreOffice 5


[$19459027]pi@raspberrypi:/etc/apt sudo apt – get install libreoffice reading lists of packages…] Done building the tree of dependencies reading state information… Done…

62 last updated 115 newly installed, 13 to remove and 820 not updated.

It is necessary to take 217 MB in the archives.

After this operation, 220 MB of additional disk space will be used.

Do you want to continue? [O/n]

as usual, answer Yes, don’t be annoying (e)…


installation starts and after a while you will be asked to restart services without your notice.



still tell him Aye and open a beer, a drink Cola or make you a cup of coffee (the?)


after a (long) while, your version of LibreOffice is updated


.../...
Libreoffice-librelogo setting (1:5.2.4 ~ rc1-1)...
Setting of libreoffice-wiki-publisher (1.2.0 + LibO5.2.4 ~ rc1-1)...
Libreoffice-nlpsolver setting (0.9 + LibO5.2.4 ~ rc1-1)...
Treatment of DSUs ("triggers") for libc-bin (2.24 - 8 + rpi1)...
Treatment of DSUs ("triggers") for libreoffice-common (1:5.2.4 ~ rc1-1)... pi@raspberrypi:/etc/apt $

Test of LibreOffice 5


good already that’s not bad, it is well LibreOffice 5 which opens 🙂




Arrgh! But it’s still in English! While we’re on is translated it into french?


LibreOffice 5 in french in the text


to frenchify LibreOffice 5 to install the package libreoffice-l10n-en


[$19459027]pi@raspberrypi:/etc/apt sudo apt – get install libreoffice-l10n-fr package… lists reading] Done building the tree of dependencies reading state information… Fact you can run ‘apt – get f install’ to correct these problems: the following packages have unmet dependencies: sonic-pi: depends: libQt5printsupport5 but it is not installable E: dependencies not met. Try ‘apt – get f install’ without a package (or specify a solution).

good priori apt – get has detected a problem in dependencies, but we kindly offers a solution… Let’s go (if you do not have this message skip next step)


[$19459027]pi@raspberrypi:/etc/apt sudo apt – get f install package… lists reading] Done building the tree of dependencies reading state information… Fact Correction of dependencies… Fact the following packages were automatically installed and are no longer required: libboost – atomic1.55.0 libboost – system1.55.0 libboost – thread1.55.0 libglew1.10 liborcus – 0.8 – 0 libpython3.4 libpython3.4 – dev libpython3.4 libelfg0 – minImal libpython3.4 – stdlib libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5 libqt5printsupport5 libqt5svg5 libqt5widgets5 libruby2.1 libscsynth1 libwps – 0.3 – 3 libxcb-icccm4 libxcb-image0 libxcb-keysyms1 libxcb-randr0 libxcb-render-util0 libxcb-xkb1 libxkbcommon – x 11-0 libyaml-0-2 python3.4 python3.4 – dev python3.4 – minimum qttranslations5-l10n ruby ruby2.1 deintegration rubygems supercollider-server please use ‘sudo apt autoremove’ to remove them.

The following packages will be REMOVED: sonic-pi 0 updated, 0 newly installed, 1 to remove and 820 not updated.

After this operation, 151 MB of disk space will be freed.

Do you want to continue? [O/n]

come on say it still Aye! We’ll deal with packages that are no longer needed later (but you can do that now if you want to)


 you want to continue? [O/n] o (reading database... 117339 files and directories already installed.)
Deletion of sonic-pi (1:2.11.0 - 0)...
Treatment of DSUs ("triggers") for mime-support (3.58)...
Treatment of DSUs ("triggers") for desktop-file-utils (0.22 - 1)...
Treatment of DSUs ("triggers") for gnome-menus (3.13.3 - 6)...

we relaunch the installation. Now the dependencies should no longer be a problem…


[$19459027]pi@raspberrypi:/etc/apt sudo apt – get install libreoffice-l10n-fr package… lists reading] Done building the tree of dependencies reading state information… Fact the following packages were automatically installed and are no longer required: libboost – atomic1.55.0 libboost – system1.55.0 libboost – thread1.55.0 libelfg0 libglew1.10 liborcus – 0.8 – 0 libpython3.4 libpython3.4 – dev libpython3.4 – minimum libpython3.4 – stdlib libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5 libqt5printsupport5 libqt5svg5 libqt5widgets5 libruby2.1 libscsynth1 libwps – 0.3 – 3 libxcb-icccm4 libxcb-image0 libxcb-keysyms1 libxcb-randr0 libxcb-render-util0 libxcb-xkb1 libxkbcommon – x 11-0 libyaml-0-2 python3.4 python3.4 – dev python3.4 – minimum qttranslations5-l10n ruby ruby2.1 deintegration rubygems supercollider-server please use ‘sudo apt autoremove’ to remove them.

Suggested packages: hunspell-dictionary-en | myspell-dictionary-hyphen-en libreoffice-grammarcheck-en libreoffice-help-myths-en NEW following packages will be installed: libreoffice-l10n-en 0 updated, 1 newly installed, 0 to remove and 820 not updated.

It is necessary to take 421 KB in the archives.

After this operation, 2 517 kb of additional disk space will be used.

Receipt of: 1 http://raspbian.42.fr/raspbian stretch/hand armhf libreoffice-l10n-en all 1:5.2.4 ~ rc1-1 [421 kB] 421 KB received in 1 s (279 KB/s) selecting previously deselected libreoffice-l10n-fr package.

(Reading database… 105352 files and directories already installed.)

Preparation of the unpacking of…/libreoffice-l10n-fr_1%3a5.2.4~rc1-1_all.deb…

Unpacking of libreoffice-l10n-fr (1:5.2.4 ~ rc1-1)…

Setting of libreoffice-l10n-fr (1:5.2.4 ~ rc1-1)… pi@raspberrypi:/etc/apt $

and we check:



Yep! We have a free office in french, all the menus are well translated 🙂


Version of LibreOffice 5 installed


make you in the menu help and click on about LibreOffice . The above screen. Well, we went to version 5.2.


and clipart?


often users who spend a commercial sequel to LibreOffice make me the note that the cliparts are a little disappointing. Let’s improve it too.


go to the menu Insert > Media > Gallery writer.


there is a list of the clipart included in LibreOffice 5.


to increase the availability of clipart, install openclipart:


[$19459027]pi@raspberrypi:/etc/apt sudo apt – get install openclipart reading lists of packages…] Done building the tree of dependencies reading state information… Fact the following packages were automatically installed and are no longer required: libboost – atomic1.55.0 libboost – system1.55.0 libboost – thread1.55.0 libelfg0 libglew1.10 liborcus – 0.8 – 0 libpython3.4 libpython3.4 – dev libpython3.4 – minimum libpython3.4 – stdlib libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5 libqt5printsupport5 libqt5svg5 libqt5widgets5 libruby2.1 libscsynth1 libwps – 0.3 – 3 libxcb-icccm4 libxcb-image0 libxcb-keysyms1 libxcb-randr0 libxcb-render-util0 libxcb-xkb1 libxkbcommon – x 11-0 libyaml-0-2 python3.4 python3.4 – dev python3.4 – minimum qttranslations5-l10n ruby ruby2.1 deintegration rubygems supercollider-server please use ‘sudo apt autoremove’ to remove them.

The following additional packages will be installed: librsvg2-2 librsvg2-bin librsvg2-common openclipart-libreoffice openclipart-png openclipart-svg suggested packages: gimp gimp-svg inkscape sodipodi sketch ksvg NEW following packages will be installed: openclipart openclipart-libreoffice openclipart-png openclipart-svg librsvg2-bin the following packages will be updated: librsvg2-2 librsvg2-common 2 updated, 5 newly installed, 0 to remove and 818 not updated.

It is necessary to take 178 MB in the archives.

After this operation, 333 MB of additional disk space will be used.

Do you want to continue? [O/n]

say Aye to install Clipart extra


we can now do some cleaning by deleting useless files:


[$19459027]pi@raspberrypi:/etc/apt sudo apt – get autoremove reading lists of packages…] Done building the tree of dependencies reading state information… Fact the following packages will be REMOVED: libboost – atomic1.55.0 libboost – system1.55.0 libboost – thread1.55.0 libelfg0 libglew1.10 liborcus – 0.8 – 0 libpython3.4 libpython3.4 – dev libpython3.4 – minimum libpython3.4 – stdlib libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5 libqt5printsupport5 libqt5svg5 libqt5widgets5 libruby2.1 libscsynth1 libwps – 0.3 – 3 libxcb-icccm4 libxcb-image0 libxcb-keysyms1 libxcb-randr0 libxcb-render-util0 libxcb-xkb1 libxkbcommon – x 11-0 libyaml-0-2 python3.4 python3.4 – dev python3.4 – minimum qttranslations5-l10n ruby ruby2.1 rubygems-supercollider-server integration put 0 updated, 0 newly installed, 38 to remove and 793 not up-to-date.

After this operation, 118 MB of disk space will be freed.

Do you want to continue? [O/n]

say Aye


once finished cleaning check the availability of Clipart:


good… This time you have clipart 🙂


restoration of sources.list


to access LibreOffice 5 we changed /etc/apt/sources.list. Let’s put things as they were before our intervention:


[$19459029]pi@raspberrypi:/etc/apt cd /etc/apt
pi@raspberrypi:/etc/apt $ sudo cp sources.list.org sources.list
pi@raspberrypi:/etc/apt $


the ‘testing’ of Raspbian version allows you to benefit from the latest version of LibreOffice.] This will be useful for those who use LibreOffice on a PC running Linux or penny Windows and want to find the same version in the Raspbian environment.


once again I draw your attention to the fact that this update may cause certain shortcomings and that it is better to achieve it on a dedicated card.


as usual do not hesitate to share your comments and suggestions in the comments below…




No comments:

Powered by Blogger.